Problem with Debian and Dropbox

Standard

I’m a Debian User. I’m using Debian 6.0 (squeeze). I have a lot of problems with my dropbox installation, because there are some dependencies which in Debian are not default. With this tutorial I hope that any debian user can install dropbox( nautilus-dropbox ) in your machine.

1)Download the .deb at Dropbox Site

wget http://www.dropbox.com/download?dl=packages/nautilus-dropbox_0.6.8_i386.deb

If you want instal, you will see an error like this:

Depends: libnautilus-extension1 (>=1:2.22.2) but 2.30.1-2 is to be installed
This dependencies are not correctly specified.

2)Create a directory, put the dropbox files in it, do some modifications and build a new version for you with
these modifications.

mkdir -p extract/DEBIAN
dpkg-deb -x  nautilus-dropbox_0.6.8_i386.deb extract/
dpkg-deb -e nautilus-dropbox_0.6.8_i386.deb extract/DEBIAN/

Edit the control file at /extract and after copy this file to /DEBIAN
You must to modify this line:

Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.6.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.12.0), 
libnautilus-extension1 (>=2.22.2), libpango1.0-0 (>= 1.20.1), python (>= 2.5), python-gtk2 (>= 2.12)
Suggests: nautilus (>= 2.16.0)

Before it was:

libnautilus-extension1 (>= 1:2.22.2) , you must to delete “1:”

3)Create a new build with these modifications:

mkdir build

dpkg-deb -b extract/ build/

With this new .deb you can install
4)dpkg -i nautilus-dropbox_0.6.8_i386.deb
5)Start dropbox: dropbox start -i
My .deb you can download here
Advertisements