Xcode 4.3.x and MacPorts

Standard

Problem:

Error: The installed version of Xcode (3.2.6) is too old to use on the installed OS version. Version 4.1 or later is recommended on Mac OS X 10.7.

Solution:

sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer/